FGFS 2020.1.1 RC Released

09 May 2020 09:50 - 09 May 2020 12:18 #46407 by Algernon
Main forum post: forum.flightgear.org/viewtopic.php?f=68&t=37413

DL link: download.flightgear.org/builds/rc/

Update: DON'T DO IT!!! It will ruin your MP experience, and there are several other issues that screwed up entire flights for me. Trying to figure them out so I can file tickets, but some are seriously problematic and worrying.
The following user(s) said Thank You: Porcius

Please Log in or Create an account to join the conversation.

09 May 2020 10:32 - 09 May 2020 10:52 #46410 by Algernon
Well, installing 2020.1.1 solved my performance issues... but there are some changes some people are not gonna like...

Like model view. Gone. Replaced with an alternative that didn't work for me, broke the scenery and ruined my flight (Terrasync stopped working after trying to view MP players, the scenery tiles around the one I was over all actually disappeared). The alternative is called "MP view legacy mode" or something, as if seeing MP players was a thing of the past. Yet another two fingers up at the MP community.

Sigh. I'd forgotten about days like these - wake up, sunny Saturday, start FlightGear, day ruined.

Please Log in or Create an account to join the conversation.

09 May 2020 11:05 #46412 by Avionyx
Don't have the huevos to try and update FG on a FlightNight day!
I'll give it till Tomorrow then I've got a full week to uninstall it and roll back before next week's is ruined.

Thanks for the heads up though, sounds like some are going to be miffed

Please Log in or Create an account to join the conversation.

09 May 2020 11:14 #46414 by Algernon
I had to reinstall anyway, thanks to the inexplicable scenery issue from last night, so I thought I might as well get the latest - I've got much of the day to get it up to speed. It's running beautifully fast, but there are some sound issues (it seems to forget to restart some samples when switching views for instance). Once I've used it a bit more and tied down potential causes for the issues, I'll feed back to the project. But that model view thing - a total disaster and is going to make filming while flying very problematic.

Please Log in or Create an account to join the conversation.

09 May 2020 11:43 #46418 by enrogue
Viewing other players is now in the multiplayer pilots list

Please Log in or Create an account to join the conversation.

09 May 2020 12:10 #46424 by Algernon
It has the same problem - jumps you to their cockpit view, hardly any of the model and no scenery loads, then when you return to your own aircraft you don't have any scenery anymore either.

Talk about a breaking change. FFS.
The following user(s) said Thank You: Porcius

Please Log in or Create an account to join the conversation.

09 May 2020 12:45 #46429 by eagle12
Hi Algy,

maybe disable terrasync before you start FG.
Or has the path changed or not selected where your terrasync folder is.
What happens when you reload the scenery or the plane?
What changes if you change the time of day from morning to night?
Or download the scenario tile by hand from the FG side.

Please Log in or Create an account to join the conversation.

09 May 2020 12:56 - 09 May 2020 12:57 #46432 by Algernon

eagle12 wrote: Hi Algy

Hey :)

Or has the path changed or not selected where your terrasync folder is.

I don't even have a separate Terrasync folder anymore - I haven't done for some years -Terrasync seems to just do its thing. Does it still need a dedicated folder?

What happens when you reload the scenery or the plane?
What changes if you change the time of day from morning to night?
Or download the scenario tile by hand from the FG side.

I'll try all these and get back to you.
Thanks!

Please Log in or Create an account to join the conversation.

09 May 2020 13:53 - 09 May 2020 13:58 #46439 by Algernon
A few more issues noticed while taxiing around... and I actually can't believe this. Spurious brake activity, possibly caused by my joystick config but certainly never experienced before - the brakes were applying themselves when the aircraft was stationary sometimes, and other times just refusing to work. Also, right-clicking the mouse button to go into "look around you"* mode - this just stopped working for a whole minute, then suddenly came back in a flurry of previous button inputs. Again, could be something to do with my custom config, but has never ever happened before.

I wonder how much more it can piss me off before this evening (or even worse, DURING this evening).

*"Write that down in your copy book now"

Please Log in or Create an account to join the conversation.

09 May 2020 17:31 #46455 by Richard

Algernon wrote: ...as if seeing MP players was a thing of the past. Yet another two fingers up at the MP community.


It's fair to say that all of the core developers are aware of the importance of the MP community and I'm always going to be there to champion MP.

I think the new view system is an improvement for MP because all views work for all MP aircraft - just click on the square on the left in the pilot view and you'll be taken to that aircraft (for the view that you currently have). So it's easy to sit in the cockpit etc.

Helicopter view does all that model view used to do except switching models - which instead can be done from the pilot view menu.

The strange behaviour you describe with the mouse has already been reported - but there isn't a reproducible way of making this happen; it's something that all of the core devs have been looking into
The following user(s) said Thank You: Algernon

Please Log in or Create an account to join the conversation.

09 May 2020 17:38 #46456 by Algernon
Well that's good to know :) I have posed on the main forums to find out if anyone else is having the scenery unloading issue, but enrogue tells me the issue has been known about for a while...

Please Log in or Create an account to join the conversation.

23 May 2020 21:14 #46778 by StuartC
Vegitation rendering was what was causing my severe isuies on the flight night. Cant run it on the same level as I did with the 2019 and earlier versions.

Please Log in or Create an account to join the conversation.

24 May 2020 06:07 #46779 by Algernon
Was that with Compositor going? Wonder if maybe it's vegetation shadows doing it...

Please Log in or Create an account to join the conversation.

24 May 2020 08:39 #46781 by StuartC
No, it was the raw 2020.1 version.

Please Log in or Create an account to join the conversation.

24 May 2020 09:13 #46782 by enrogue
One thing that I noticed has changed is how texture cache is turned on - its now in the main launcher Settings->Rendering->Show more->Cache graphics for faster loading

this overrides the setting in game - it might be causing your slowdown

Please Log in or Create an account to join the conversation.

24 May 2020 09:40 #46783 by timi
I was wondering why the in game setting don't stick. It's always off when I come back to it.

Please Log in or Create an account to join the conversation.

24 May 2020 09:41 #46784 by StuartC
I use RGrun, not the QT launcher.
Downloading 2020.1.2 now to see if its any different

Please Log in or Create an account to join the conversation.

24 May 2020 10:18 #46785 by StuartC
2020.1.2 has the same issue. 20fps difference at LFLS between High vegitation and Very high vegitation ( which is what I would normally run at ).

Please Log in or Create an account to join the conversation.

24 May 2020 10:50 #46786 by Algernon
Did you try disabling vegetation shadows in Rendering Options?

Please Log in or Create an account to join the conversation.

24 May 2020 10:58 #46787 by StuartC
not yet

Please Log in or Create an account to join the conversation.

Time to create page: 0.337 seconds
Powered by Kunena Forum

Latest Forum Posts

PM Notifications

You are not logged in.

PM Mailbox

You are not logged in.